WordPress and IE9

So after a month or so of using IE9, and not being able to update this blog without RDP’ing into a 2008 R2 server with IE8 – wordpress seem to have updated for IE9 – cool…. but… whenever i open the dashboard i get a large warning stating that my version of IE is out of date!

Those whacky wordpress guys!